Most popular WordPress versions are currently affected.
A stored cross-site scripting (XSS) vulnerability available in the recently released WordPress 4.2 and earlier versions can be exploited by an unauthenticated party to run arbitrary code on the server; the security glitch is currently unpatched and proof-of-concept code is publicly available.
An attacker taking advantage of the flaw could take control of the targeted website by creating new admin accounts. Aside from the current WordPress versions, build 4.1.2, 4.1.1 and 3.9.3 are also affected. Comment text truncation issue still not fully fixed.
Discovered by Jouko Pynnönen, from vulnerability research firm Klikki Oy in Finland, the flaw is similar to the one patched in WordPress 4.1.2, after having been disclosed to the developer by researcher Cedric Van Bockhaven about 14 months ago, on February 23, 2014.
Bockhaven’s approach consisted in introducing a character in the message that truncates the text at a specific point, turning it into a script that executes malicious code on the server upon a certain action, such as “mouseover.”
Pynnönen’s method differs only in the way truncation of the text is achieved, which occurs when the comment is stored in the website’s database.
Comments that are larger than 64kb are truncated via MySQL. One way to reach the limit is to paste random characters after the malicious part has been included.
continue reading at Softpedia.com
Our hosting provider Moscom.com is already applying the latest update to our core content management system. If you haven't done so, check with your hosting provider regarding this vulnerability and ask how they handling to secure (patch) your website.